[Not Tetris 2] game stuck after multiplayer with scale >= 7

Problems running games? Right in here.
oxygen
Posts: 3
Joined: 09 Mar 2012, 01:38

Post » 09 Mar 2012, 02:13

Hello there :) thank you for your well done games.

The game works completely fine, except for 2-player mode with scale set to 7, 8, or fullscreen on. Setting the scale to anything < 7 fixes the problem.
  • Symptoms: After both players have reached the top and failed, the end animation is displayed and when all bricks left the screen nothing happens or responds.
    • System:
      OS: Win XP SP3
      Graphics: ATI Radeon X1950 Pro (1920x1200 @ 60Hz)
      Driver Version: 09.3 (Release Version: 8.591-090225a-076825C-ATI)
      • Screenshot: http://i41.tinypic.com/2gseq6w.png
      regards,
      oxygen

      DatAsh
      Posts: 7
      Joined: 09 Mar 2012, 00:09

      Post » 09 Mar 2012, 03:11

      I like your dedication to the game and all, but...


      I'm pretty sure they stopped working (if they were even trying) on this game, so if this is a tech issue, they most likely wont fix it.

      Also: I tested it; it works fine for me.




      Sinceraly,
      Me and my Microwave

      User avatar
      Sašo
      Stabyourself.net
      Posts: 1427
      Joined: 06 Jan 2012, 12:07

      Post » 09 Mar 2012, 17:13

      DEAR EVERYONE: THIS IS A PRIME EXAMPLE OF A GREAT BUG REPORT. PLEASE LEARN FROM THIS MAN.

      Yeah, that's a known bug, though it might take a while before the fix is out. Pretty much everything that's not Mari0 is currently on hold until Mari0 is... stable. Can't really say what that means or that would be.

      oxygen
      Posts: 3
      Joined: 09 Mar 2012, 01:38

      Post » 10 Mar 2012, 07:01

      Haha, now I feel very honored :D

      No worries, it's only a minor bug. The only real prolbem with Not Tetris 2, is that this game can be highly addictive! (nearly missed an exam at university :P)

      Since you are currently busy, I fixed it up for you:

      [gameBmulti.lua] line: 417 + 423

      Code: Select all

      if v:getY() < 162*mpscale then
      Comparing an unscaled value with a scaled constant, caused the irregular behaviour.
      If we take the default scale, we get a threshold of 162*5 = 810, which looks like a good value considering the worldsize of 1050.

      If you simply replace those two lines with:

      Code: Select all

      if v:getY() < 810 then
      2-player-mode will work with every scale.

      ps: Keep up the good work with Mari0 ;)

      Maurice
      Stabyourself.net
      Posts: 2143
      Joined: 01 Feb 2012, 20:19

      Post » 10 Mar 2012, 14:10

      Actually physics scale is 2 iirc. Looks like I forgot to change that part when I seperated the physics from the scale.

      oxygen
      Posts: 3
      Joined: 09 Mar 2012, 01:38

      Post » 10 Mar 2012, 16:50

      actually it's mpscale/4 ;) but now it makes sense. yeah, so either add *physicsmpscale to v:getY(), or fix the value to 648.