Streaming game development: https://www.twitch.tv/stabyourself Image

Mari0 SE P-Switch

LucasOfficialMC
User avatar
Posts: 4
Joined: 09 Dec 2016, 18:40
Reputation: 0

Post » 05 Feb 2017, 20:32

Hey, do someone know how can i do / code a P-Switch for Mari0 SE, or maybe if some can tell me where to find one.
Thanks

QwertymanO07
User avatar
Posts: 1270
Joined: 05 Oct 2012, 07:58
Reputation: 333
Contact:

Post » 05 Feb 2017, 21:02

Keep in mind that I haven't actually tried this yet, but I imagine that you can use triggered animated tiles that swap from bricks to coins.

WillWare
User avatar
Posts: 1217
Joined: 08 Mar 2012, 04:35
Reputation: 265
Contact:

Post » 05 Feb 2017, 22:05

Coins don't work correctly as animated tiles, unfortunately, so switching between brick/coin like that wouldn't work. It would have to be an entity of some kind.

I don't know of any mods for SE that have a P-Switch, but Alesan's Entities (a mod for 1.6) has one, and also includes many features from SE. Could be worth the conversion.

LucasOfficialMC
User avatar
Posts: 4
Joined: 09 Dec 2016, 18:40
Reputation: 0

Post » 06 Feb 2017, 08:10

I know, i tried to use this version, but in the files of Alesan's Entities version, this is only for 1.6 Mari0, and not Mari0 SE, but i'll retry.

LucasOfficialMC
User avatar
Posts: 4
Joined: 09 Dec 2016, 18:40
Reputation: 0

Post » 06 Feb 2017, 08:21

Yup, i tried with the leaf this time, but everytime i'm placing the leaf, nothing appears, the leaf is right in the editor, but NOTHING appears in game.. Just like the P-Switch...

alesan99
User avatar
Posts: 1623
Joined: 30 May 2013, 21:42
Reputation: 255
Contact:

Post » 06 Feb 2017, 13:49

LucasOfficialMC wrote:Yup, i tried with the leaf this time, but everytime i'm placing the leaf, nothing appears, the leaf is right in the editor, but NOTHING appears in game.. Just like the P-Switch...

You have to place them in ? blocks.

LucasOfficialMC
User avatar
Posts: 4
Joined: 09 Dec 2016, 18:40
Reputation: 0

Post » 06 Feb 2017, 19:44

That's what i did, but when i'm hurting the block theres the "mushroomappears.ogg" sound, but nothing is coming out of the block. Maybe that's an incompability between Mari0 SE & Mari0 1.6 (or modded)


Return to “Mari0”

Who is online

Users browsing this forum: No registered users and 2 guests

cron