Streaming game development: https://www.twitch.tv/stabyourself Image

Game won't start

HeroKing
User avatar
Posts: 104
Joined: 10 Feb 2012, 23:57
Reputation: 0

Post » 04 Mar 2012, 00:16

most likely unlike the rest of the people here, i'm a linux user, so i use the linux version of the game. but any time i try to start it up, i get the blue error screen

Code: Select all

main.lua:41: attempt to call field 'setDefaultImageFilter' (a nil value)

Traceback

main.lua:41: in function 'load'
[C]: in function 'xpcall'

tesselode
User avatar
Posts: 155
Joined: 04 Feb 2012, 05:33
Reputation: 2

Post » 04 Mar 2012, 00:18

You need Love 0.8.0.

HeroKing
User avatar
Posts: 104
Joined: 10 Feb 2012, 23:57
Reputation: 0

Post » 04 Mar 2012, 00:20

yeah, found that out on another thread. now i'm trying to find it since it's not available in the repos, and the love2d site is confusing on the lists. not to mention they seem to be only for windows builds

bambo
User avatar
Posts: 59
Joined: 02 Feb 2012, 21:37
Reputation: 0
Contact:

Post » 04 Mar 2012, 00:23

it should work straight from the binaries, the binaries are pretty much love 0.8.0 itself so don't bother downloading it.

Just make sure you extract EVERYTHING onto say... your desktop or something.

HeroKing
User avatar
Posts: 104
Joined: 10 Feb 2012, 23:57
Reputation: 0

Post » 04 Mar 2012, 00:27

ok, got it working on the windows .exe file. bit of a hassle having to use wine instead of my native install

Edit: though now, only thing i see is the sprites of characters and ? blocks. the environment is completely gone

bambo
User avatar
Posts: 59
Joined: 02 Feb 2012, 21:37
Reputation: 0
Contact:

Post » 04 Mar 2012, 00:28

that is VERY strange... it should work fine on linux. Hopefully it is an isolated case.

trosh
User avatar
Posts: 1596
Joined: 03 Feb 2012, 08:36
Reputation: 8
Contact:

Post » 04 Mar 2012, 00:30

love-unstable isn't in your repo ? maybe you don't have an appropriate distro. If you're running ubuntu, it should work

HeroKing
User avatar
Posts: 104
Joined: 10 Feb 2012, 23:57
Reputation: 0

Post » 04 Mar 2012, 00:32

i've been running 10.10 for months now (i refuse to update any further) and the package manager only has 0.7.2 available. i don't see the unstable version anywhere, unless i need a ppa patch installed

Irubataru
Posts: 6
Joined: 04 Mar 2012, 00:31
Reputation: 0

Post » 04 Mar 2012, 00:41

Just add the repository ppa:bartbes/love-unstable

Code: Select all

sudo add-apt-repository ppa:bartbes/love-unstable
sudo apt-get update

trosh
User avatar
Posts: 1596
Joined: 03 Feb 2012, 08:36
Reputation: 8
Contact:

Post » 04 Mar 2012, 00:52

yeah, sorry, my bad. had forgotten about that. ALSO YES 10.10 ALL THE WAAAAAYYYY I'm just like you, except at first i did upgrade but then after like two weeks ubuntu 11.04 just stopped working, so I just reinstalled 10.10

HeroKing
User avatar
Posts: 104
Joined: 10 Feb 2012, 23:57
Reputation: 0

Post » 04 Mar 2012, 00:52

got it working now. thanks for the help guys ^^ now i just have to try and get used to the controls lol


Return to “Mari0”

Who is online

Users browsing this forum: No registered users and 3 guests

cron