Streaming game development: https://www.twitch.tv/stabyourself Image

Shall we start updating to 0.9.0?

Stabyourself related discussion, announcements
Firaga
User avatar
Posts: 944
Joined: 02 Jul 2012, 16:05
Reputation: 118
Contact:

Post » 05 Aug 2013, 20:03

If it's not broke, don't fix it.
0.8.0 is fine for now, and I don't know if Maurice has any plans for changing it.

Automatik
User avatar
Posts: 1076
Joined: 20 Jul 2012, 17:54
Reputation: 8
Contact:

Post » 05 Aug 2013, 22:29

Good idea.
I've done a plug&play lib to convert 0.8.0 games to 0.9.0:
http://hastebin.com/hawituyala.lua
It don't have everything(Not the thread stuff) but for most things it should be ok

Sašo
Stabyourself.net
User avatar
Posts: 1380
Joined: 06 Jan 2012, 12:07
Reputation: 318
Contact:

Post » 05 Aug 2013, 23:26

Considering the changes so far (dammit slime) it's just gonna end up being an indefinite process

Qcode
User avatar
Posts: 1464
Joined: 05 Feb 2012, 18:00
Reputation: 72
Contact:

Post » 06 Aug 2013, 02:33

It won't work because mari0 uses threading to fix love music bugs.

Automatik
User avatar
Posts: 1076
Joined: 20 Jul 2012, 17:54
Reputation: 8
Contact:

Post » 06 Aug 2013, 08:22

WaryLouka wrote:
Automatik wrote:Good idea.
I've done a plug&play lib to convert 0.8.0 games to 0.9.0:
http://hastebin.com/hawituyala.lua
It don't have everything(Not the thread stuff) but for most things it should be ok


.. and how i shall use this on actual projects?
I want to use it on my Mari0: Lite Edition

You put the .lua in the root folder and then require() it.
Though as QCode said, Mari0 use threading(so it won't work), and as Saso said, we better should wait for 0.9.0 to come-out.


Return to “Stabyourself.net”

Who is online

Users browsing this forum: No registered users and 2 guests