Streaming game development: https://www.twitch.tv/stabyourself Image

[v1.1 - DISCONTINUED] Mari0:HEC (HugoBDesigner's Entities and Customization)

Mods, guides how to use and install mods go right in here.
Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 17 Aug 2014, 19:08

Do you know how to translate the game?

Because I would like to translate the game into Italian! :D

EDIT: PAGE 17!!!!!

Mari0Maker
User avatar
Posts: 1347
Joined: 07 Apr 2012, 17:10
Reputation: 39
Contact:

Post » 17 Aug 2014, 19:19

This should be the latest template to translate the game with. The post was from here.
Also note that you only change the "englishus" to "italian," and the second word/sentence, leaving the one beforehand unchanged, so like this for example.

Code: Select all

language["italian"]["main"] = "principale"

So, just change all of this to Italian.

Code: Select all

--Update 2:
language["englishus"]["main"] = "main"
language["englishus"]["tiles"] = "tiles"
language["englishus"]["tools"] = "tools"
language["englishus"]["maps"] = "maps"
language["englishus"]["black"] = "black"
language["englishus"]["blue"] = "blue"
language["englishus"]["water"] = "water"
language["englishus"]["overworld"] = "overworld"
language["englishus"]["underground"] = "underground"
language["englishus"]["castle"] = "castle"
language["englishus"]["custom"] = "custom"
language["englishus"]["custom2"] = "custom 2"
language["englishus"]["custom3"] = "custom 3"
language["englishus"]["custom4"] = "custom 4"
language["englishus"]["star"] = "star"
language["englishus"]["transparent"] = "transparent"
language["englishus"]["opaque"] = "opaque"
language["englishus"]["save"] = "save"
language["englishus"]["return to menu"] = "return to menu"
language["englishus"]["test level"] = "test level"
language["englishus"]["apply"] = "apply"
language["englishus"]["all"] = "all"
language["englishus"]["smb"] = "smb"
language["englishus"]["portal"] = "portal"
language["englishus"]["objects"] = "objects"
language["englishus"]["entities"] = "entities"
language["englishus"]["categorized"] = "categorized"
language["englishus"]["default"] = "default"
language["englishus"]["technical"] = "technical"
language["englishus"]["super mario bros"] = "super mario bros"
language["englishus"]["link tool|to link testing equipment, drag a line from the|red devices to a yellow activator to turn them|green and connected. insert zelda joke here."] = "link tool|to link testing equipment, drag a line from the|red devices to a yellow activator to turn them|green and connected. insert zelda joke here."
language["englishus"]["portal gun|for testing purposes, use this to shoot portals!"] = "portal gun|for testing purposes, use this to shoot portals!"
language["englishus"]["mappack title:"] = "mappack title:"
language["englishus"]["mappack title"] = "mappack title"
language["englishus"]["author:"] = "author:"
language["englishus"]["author"] = "author"
language["englishus"]["description:"] = "description:"
language["englishus"]["description"] = "description"
language["englishus"]["custom player name:"] = "custom player name:"
language["englishus"]["custom player name"] = "custom player name"
language["englishus"]["lives:"] = "lives:"
language["englishus"]["lives"] = "lives"
language["englishus"]["save settings"] = "save settings"
language["englishus"]["save on your mappack"] = "save on your mappack"
language["englishus"]["save on customlevels"] = "save on customlevels"
language["englishus"]["edit player"] = "edit player"
language["englishus"]["-if compatible with|vanilla mari0 or if|you haven’t added|any custom entity."] = "-if compatible with|vanilla mari0 or if|you haven’t added|any custom entity."
language["englishus"]["-if compatible with|either mari0 +portal|or vanilla mari0."] = "-if compatible with|either mari0 +portal|or vanilla mari0."
language["englishus"]["move up"] = "move up"
language["englishus"]["move down"] = "move down"
language["englishus"]["delete"] = "delete"
language["englishus"]["rename"] = "rename"
language["englishus"]["world (abbreviation: w)"] = "w"
If you need UTF-8 characters, you can go here as a reference just incase.
viewtopic.php?p=98530#p98530


Regarding the update, it's looking great. I should spend some more time with your mod, but I'm busy like pretty much everyone else on here. Keep it up. :)

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 17 Aug 2014, 21:28

I translated it (almost) everything in Italian, the only problem is that when I turn the game and I'm going to choose the language, Italian don't appears! :(

What did I do wrong?

HansAgain
User avatar
Posts: 1135
Joined: 03 Feb 2012, 18:51
Reputation: 265
Contact:

Post » 17 Aug 2014, 21:52

Did you change the "englishus" in every line with "italian"?

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 17 Aug 2014, 22:05

Yes, every line is Italian, but still does not appear! That boredom!!! D:

EDIT: Look what I found, simply add the Italian language at line 78 of main.lua! ^o^

Now I have the game in Italian, thanks for the help!

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Aug 2014, 10:35

That sounds nice! Could you share it here, so I can officially add it to the next version of the mod? Thanks :)

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 18 Aug 2014, 12:00

Here It Is: http://www.mediafire.com/view/kqrl3hka94xo383/italian_it.lua

I hope you like Hugo! :D


I also wanted to tell you that when I select the level editor crashes the game! Why? :(

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Aug 2014, 13:29

That only happens if the selected mappack is corrupted somehow. Did you play this mappack on another mod? Send me the error you got (on %appdata%/LOVE/mari0/errors) so I can see if it's caused by my mod or your mappack.

Also thanks for the Italian translation!

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 18 Aug 2014, 14:00

1) I tried with any mappack but it doesn't work anyway!

2) Is not an error, crashes the game and just, not error screen!

3) I'm playing with Mario + Portal 0.9.9 beta 2

4) There is that! I hope I have helped! :D

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Aug 2014, 18:27

Hmm... This is very unusual...
One last thing: try the default smb mappack. If it works, then it's something about your mappacks. If not, then the mod is closing by itself. Maybe it takes too much memory from your computer? I don't know if this could be the problem, since I removed most of the memory-taking things in earlier versions (other people couldn't play anything without the game closing). My computer is very bad but still runs the mod fine :S

Wary
User avatar
Posts: 638
Joined: 03 Jun 2012, 14:30
Reputation: 57

Post » 18 Aug 2014, 18:43

If you need the game translated in Russian or Spanish, tell me.

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 18 Aug 2014, 18:49

Nothing works anyway!!!

If you want I'll give you the details of my computer:

Code: Select all

Windows 7 Home Premium 64-bit SP1

Intel Core 2 Duo E6300 @ 1.86GHz   
Technology Conroe 65nm

4,00GB Single Channel DDR2 @ 398 MHz (5-5-5-18)

ASUSTeK Computer INC. P5B-Deluxe (LGA 775)   

T24B300 (1920x1080@60Hz)
1024 MBATI AMD Radeon HD 5700 Series (ASUStek Computer Inc)   

Device High Definition Audio

B-Man99
So long, and thanks for all the fish.
Posts: 1922
Joined: 02 Jul 2012, 00:32
Reputation: 415
Contact:

Post » 18 Aug 2014, 18:58

What exactly doesn't work?

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Aug 2014, 19:00

WaryLouka wrote:If you need the game translated in Russian or Spanish, tell me.

They're both welcome, thanks!

Sergione wrote:Nothing works anyway!!!

If you want I'll give you the details of my computer:

Code: Select all

Windows 7 Home Premium 64-bit SP1

Intel Core 2 Duo E6300 @ 1.86GHz   
Technology Conroe 65nm

4,00GB Single Channel DDR2 @ 398 MHz (5-5-5-18)

ASUSTeK Computer INC. P5B-Deluxe (LGA 775)   

T24B300 (1920x1080@60Hz)
1024 MBATI AMD Radeon HD 5700 Series (ASUStek Computer Inc)   

Device High Definition Audio

I don't see anything particularly "bad" to make the mod not work. Tell me, do previous versions work or none? Maybe it's due to something that got added to the beta 2...

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 18 Aug 2014, 19:28

I tried with version 0.9.7 of the mod (you ask why I did not do it with version 0.9.9: because when the turn comes this error:)

Code: Select all

Error

shaders/init.lua:1: Invalid graphics feature: pixeleffect


Traceback

main.lua:3713: in function <main.lua:3694>
[C]: in function 'isSupported'
shaders/init.lua:1: in main chunk
[C]: in function 'require'
main.lua:275: in function 'load'
[C]: in function 'xpcall'


You can get a copy of this error at:
%appdata%/LOVE/mari0/errors

And you can send it to:
http://hugobdesigner.blogspot.com.br/p/contact.html


And it works perfectly with 0.9.7!

You may adjust in the next update? :)
Last edited by Sergione on 19 Aug 2014, 10:12, edited 1 time in total.

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Aug 2014, 20:08

I don't think there was language setting for Mari0 +Portal 0.9.7, it was added in a more recent version. Try the mod in this version without adding the Italian translation (the unmodified file of M+P 0.9.7).

But now that you mentioned, I should add an easier way of installing languages to the mod by adding the files to %appdata% instead of doing it by modding. Thanks for the idea!

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 18 Aug 2014, 22:37

There is no to that! :D

I hope that very soon releases the mod! I can't wait to play! :)

Wary
User avatar
Posts: 638
Joined: 03 Jun 2012, 14:30
Reputation: 57

Post » 18 Aug 2014, 23:14

HugoBDesigner wrote:
WaryLouka wrote:If you need the game translated in Russian or Spanish, tell me.

They're both welcome, thanks!


Yeah, if you want Russian, you'll have to integrate Cyrillic characters into your mod.
As for spanish, I'm working on it.

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 19 Aug 2014, 10:11

HugoBDesigner wrote:I don't think there was language setting for Mari0 +Portal 0.9.7, it was added in a more recent version. Try the mod in this version without adding the Italian translation (the unmodified file of M+P 0.9.7).

My fault! To tell you the truth the error was this:

Code: Select all

Error

shaders/init.lua:1: Invalid graphics feature: pixeleffect


Traceback

main.lua:3713: in function <main.lua:3694>
[C]: in function 'isSupported'
shaders/init.lua:1: in main chunk
[C]: in function 'require'
main.lua:275: in function 'load'
[C]: in function 'xpcall'


You can get a copy of this error at:
%appdata%/LOVE/mari0/errors

And you can send it to:
http://hugobdesigner.blogspot.com.br/p/contact.html

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 19 Aug 2014, 13:20

This is happening because you're probably playing the mod in LÖVE 0.9.0. I fixed most of the problems that were impeding the mod from running in this version, but you still have to play it on LÖVE 0.8.0...

WaryLouka wrote:Yeah, if you want Russian, you'll have to integrate Cyrillic characters into your mod.
As for spanish, I'm working on it.

Could you give me a list of Cyrillic characters so I can add them to the mod? Thanks for the help so far :)

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 19 Aug 2014, 14:58

HugoBDesigner wrote:This is happening because you're probably playing the mod in LÖVE 0.9.0. I fixed most of the problems that were impeding the mod from running in this version, but you still have to play it on LÖVE 0.8.0...

Image


:(


EDIT: 150th POST!!! :D

Wary
User avatar
Posts: 638
Joined: 03 Jun 2012, 14:30
Reputation: 57

Post » 19 Aug 2014, 15:32

HugoBDesigner wrote:
WaryLouka wrote:Yeah, if you want Russian, you'll have to integrate Cyrillic characters into your mod.
As for spanish, I'm working on it.

Could you give me a list of Cyrillic characters so I can add them to the mod? Thanks for the help so far :)


О
E
A
И
H
T
C
Л
B
P
К
M
Д
П
Ы
У
Б
Я
Ь
Г
З
Ч
Й
Ж
X
Ш
Ю
Ц
Э
Щ
Ф
Ё
Ъ

MM102
User avatar
Posts: 1015
Joined: 11 May 2012, 06:08
Reputation: 498

Post » 19 Aug 2014, 20:14

there should be a character map on your computer somewhere
Image

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 06 Sep 2014, 14:22

Pity that still has not released the 1.0 version, I'm still waiting, Hugo!

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 06 Sep 2014, 16:02

I'm sorry for not updating it so often. I'm participating on Love Jam #2, so I didn't touch the mod lately AT ALL. But it ends up tomorrow, so I'll return working on my mod. Since I'm not adding any new feature to the next update but only fixing bugs (in order to have a decently stable version again), the next mod release will hopefully be even sooner than it was meant to be :)
Also, thanks for the support :D

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 06 Sep 2014, 16:07

Oh, I understand, then good luck with the game, try to win! :D

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 06 Sep 2014, 16:09

Thank you! I'll try to, but even if I don't, at least I'm training for future game jams, so it's being good for me already :)
(by the way, you can see little progress updates about it on my Twitter if you want)

EDIT: It seems like the jam is now due to finish in 3 days. It's good news for me, so I have more time to work on my game, but it'll also delay a bit my return on working on the mod...

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 12 Sep 2014, 23:36

I saw that the Love Jam # 2 is finished, I hope you win!

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 13 Sep 2014, 01:44

I won't, cause I didn't have enough time to finish my game. But I'll finish the game I was working on, cause it was going on greatly :)

OrbitalBlueprint
User avatar
Posts: 600
Joined: 08 Sep 2013, 20:11
Reputation: 309
Contact:

Post » 16 Sep 2014, 17:13

Since Hugo hasn't posted a link here yet, I'll do so: Quick update for Mari0+Portal 12

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 16 Sep 2014, 19:12

Heh, almost forgot of that. I put it in the main post but forgot to make a new post about it, so thanks :P

Snowburger
User avatar
Posts: 85
Joined: 23 Jun 2014, 21:21
Reputation: 0

Post » 09 Oct 2014, 20:12

This mod isn't dead is it?Please tell me it isn't.

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 09 Oct 2014, 21:10

I'm sorry, Snowburger, but yes, it is. I barely do anything related to Mari0 nowadays: neither mods nor mappacks, so I haven't touched this mod in a very long time. I know you like it and all, but now that Mari0:SE is out barely anyone cares about mods. I'm really, really sorry <:(

If you want, I can upload the latest version. It doesn't have many changes, but it has some bug fixes and all of the latest updates I've talked about.

But, other than that, you can still use Alesan's mod if you want. It has a lot of things similar to my mod, plus it is way more bug-free AND Alesan is still updating it (as far as I know). Also, he's 2000% better at adding requests than I am, so there's that.


Again, I'm sorry. I know you really like this mod, and you can be 100% sure I really appreciate it, but there wasn't going to be much more to do for this mod :S

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 09 Oct 2014, 21:18

Noooooo! Why Hugo, why? :'''''''(

You cannot, expecting for almost three months the fantastic update, and now you tell me that stays put as well?

That boredom, however much I have already the Alesan mod, and I must say that is not bad!
However, I regret that the 1.0 version might not arrive, shame really!

Snowburger
User avatar
Posts: 85
Joined: 23 Jun 2014, 21:21
Reputation: 0

Post » 09 Oct 2014, 21:53

The FULLversion of SE?Anyway,it's unfortunate that the mod is "Officially Dead Now :(" but I can survive with 0.9.9.Still though,it'd be nice for me to have the latest version,if it still has the ne items like mirror gel and stuff.If it just fixes bugs though,don't bother.Good luck with other things though.

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 09 Oct 2014, 22:24

Sergione wrote:Noooooo! Why Hugo, why? :'''''''(

You cannot, expecting for almost three months the fantastic update, and now you tell me that stays put as well?

There wasn't going to be anything extraordinarily fantastic to this update. As in the last time I mentioned it, it was mostly going to be bug-fixing, and I fixed a lot of bugs, so it's not all that bad. Also, the mod didn't become "obsolete" now that it is dead. It is just not going to be updated, but you can still use it pretty safely :)

Sergione wrote:That boredom, however much I have already the Alesan mod, and I must say that is not bad!
However, I regret that the 1.0 version might not arrive, shame really!

I'm calling the version I'm releasing now as 1.0, because, even though it is not 100% finished, I made what I said I was going to make for this release ;)


Snowburger wrote:The FULLversion of SE?Anyway,it's unfortunate that the mod is "Officially Dead Now :(" but I can survive with 0.9.9.Still though,it'd be nice for me to have the latest version,if it still has the ne items like mirror gel and stuff.If it just fixes bugs though,don't bother.Good luck with other things though.

I got the mirror gel, bug fixes and all the good stuff you can check on my latest posts here or in my blog.


For you all, thank you so much for your support and patience. I know this kinda died unfinished, but it was incredibly fun to do this mod, and you guys were nice to me from the very first version (the "custom textures only" version) until now!

I want to thank mostly one guy: Qcode. Man, without you this mod wasn't going to be possible at all, and I REALLY, REALLY appreciate your patience with me when I knew only a little of coding. I also kinda promised you to add you as the co-author on my 1.0 update, so you'll finally get this.

To anyone else, here's the download link:
Mari0 +Portal 1.0

HowToEatGirafes
User avatar
Posts: 599
Joined: 05 Feb 2014, 23:18
Reputation: 97
Contact:

Post » 09 Oct 2014, 22:32

Noooo ! Why ! One of the Image just died ! Mods are progressively dieing :( .

Sergione
Posts: 217
Joined: 07 May 2014, 16:02
Reputation: 4
Contact:

Post » 09 Oct 2014, 22:44

Ok, I start to download it, I can't wait to try it out, starting with 0.9.1, and crash!

That boredom, the move to 0.8.0, and it works! Then I want to see what new things you added and I must say it is fine, the only problem and that if you don't put in default, some things do not take! Then I want to try the level:

Code: Select all

Error

game.lua:3572: Could not open file mappacks/custom_mappack_5/1-1.txt. Does not exist.


Traceback

main.lua:3448: in function <main.lua:3429>
[C]: in function 'read'
game.lua:3572: in function 'loadmap'
game.lua:3519: in function 'startlevel'
editor.lua:3260: in function 'func'
gui.lua:532: in function 'mousepressed'
main.lua:2701: in function 'mousepressed'
[C]: in function 'xpcall'


You can get a copy of this error at:
%appdata%/LOVE/mari0/errors

And you can send it to:
http://hugobdesigner.blogspot.com.br/p/contact.html


In short, I know you've stopped, but please try to fix these bugs, I have an absolute desire to try it at 100%! :'''''''(

Apart from the rest, it is a great job! Pity that the mod, always and always, sooner or later cease to receive update! Too bad!

EDIT: You forgot the translation into Italian!

B-Man99
So long, and thanks for all the fish.
Posts: 1922
Joined: 02 Jul 2012, 00:32
Reputation: 415
Contact:

Post » 09 Oct 2014, 22:46

Shouldn't you say "finished" instead of "dead?" People are still using this no doubt... it's a great mod. Most of the features aren't obsolete - it's pretty powerful as far as mods go.

Congrats on the 1.0 release by the way

Wary
User avatar
Posts: 638
Joined: 03 Jun 2012, 14:30
Reputation: 57

Post » 10 Oct 2014, 00:09

The latest good thing you can do is converting it to 0.9.x so I won't have to manually change shit around every time I want to play a god damn mod for 10 minutes.

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 10 Oct 2014, 01:47

Okay, let me get somethings a little clear:

- I was working on making this compatible with either 0.8.0 or 0.9.x, but didn't get to finish it (I was having problems with sound playing). I may finish this, though, since it shouldn't be a big deal.
- As far as I can remember, I added every translation people gave me. So, if you want Italian translation, a translation text is always welcome! (you can find some examples a few pages ago)
- A mappack crashing while you play is most likely a sign that you used another mod with it. From the last time I checked, there wasn't any problem playing vanilla mappacks (or mappacks made on the mod). Could you give more information, please?
- Last, but not least, I'll change the title to "Finished" (and do the same on Mod's Guide and Rating). I'll probably fix some bugs eventually, but not in a regular basis.

Again, thank you all for your kindness, you guys are awesome :D

EDIT: I just realized I'll have to update the main post with a f*ckton of new information, so this will definitely take a while, since I'm by far not in a mood to rewrite a giant post :P

B-Man99
So long, and thanks for all the fish.
Posts: 1922
Joined: 02 Jul 2012, 00:32
Reputation: 415
Contact:

Post » 10 Oct 2014, 02:51

That's the spirit! :D
You're awesome too. Good luck with the main post.

Snowburger
User avatar
Posts: 85
Joined: 23 Jun 2014, 21:21
Reputation: 0

Post » 10 Oct 2014, 09:00

The FULLversion of SE?

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 10 Oct 2014, 15:25

Snowburger wrote:
The FULLversion of SE?

Sorry, forgot to answer: no, it is only the beta, but most users here are using it. It has some bugs too, but nothing you can't work around with. Pretty similar to my mod!

Also, SE has got custom enemies and animations, which my mod doesn't have (mine has animations, but in SE they're WAAAY easier to use).


EDIT: I renamed the mod to Mari0:HEC because that's what I was planning on doing for the 1.0 update. Mari0:HEC means "HugoBDesigner's Entities and Customization" (if you've already downloaded the latest version you probably already saw it). Later I'll update the full post and make it looking awesome with all the needed information!

One last thing: I made a post on my blog talking about it and a few other things. CHECK HERE.

Mari0_Player
User avatar
Posts: 415
Joined: 23 Sep 2013, 00:48
Reputation: 48

Post » 11 Nov 2014, 21:57

http://hugobdesigner.blogspot.com/ wrote:FINNALY, OFFICIALLY Mari0 +Portal 1.0 is out!!!

I can't see the download anywhere...

Automatik
User avatar
Posts: 1076
Joined: 20 Jul 2012, 17:54
Reputation: 8
Contact:

Post » 11 Nov 2014, 22:03


HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 11 Nov 2014, 22:24

It was like... A few posts above. But yeah, I should have really put it in the main post, just doing it now :)

B-Man99
So long, and thanks for all the fish.
Posts: 1922
Joined: 02 Jul 2012, 00:32
Reputation: 415
Contact:

Post » 18 Feb 2015, 06:13

Couldn't help but notice that this still has the old name of the mod on it. Not sure if you cared. Anyways, since the "completed" version is out, I think I may get into this. Thanks for the awesome mod, and good luck on your future projects! I can't believe it slipped my mind and took this long to say that :P

HugoBDesigner
User avatar
Posts: 2116
Joined: 19 Sep 2012, 02:23
Reputation: 668
Contact:

Post » 18 Feb 2015, 06:21

Wow, thank you, both for pointing the blog thing and for the compliment!
As for the mod itself, I said it was ready but it was more like I was done with it. There was way more that I wanted to do with it, but, the way it was, redoing it from ground up would probably work better, especially for the bug fixes. I didn't even finish some of the primary ideas I had (custom enemies, online mappack download, etc.), and people didn't really wanted the level of customization I was trying to reach (all they wanted was to make a few enemies and a few new entities, not advanced commands with custom variables and random environment triggers).
I feel like today I could do a mod WAAAAAY better than Mari0 +Portal was, and make it PROPERLY Mari0:HEC instead of just renaming it (so it'd be a new mod with a fresh start), but lately there hasn't been much to Mari0. I haven't got much interest in making maps or mods for it, and Alesan's Entities is handling the mods fans pretty well, so I probably still won't touch Mari0 in a very long time, but me and the Tiny Turtle Industries have been working on some pretty cool projects that will probably make up for the lack of Mari0-related content.

But overall, thanks for the feedback. I really enjoyed it and everyone else's feedbacks, mappacks, suggestions, etc. This was definitely the greatest mod Stabyourself ever saw not because of it's content, but because of how much I enjoyed it. It was always fun :)

B-Man99
So long, and thanks for all the fish.
Posts: 1922
Joined: 02 Jul 2012, 00:32
Reputation: 415
Contact:

Post » 18 Feb 2015, 07:29

What version of LOVE do I need for this? It ain't 0.9.2, that's for sure. Told me I had the wrong version then gave some error about a boolean showing up where a table was expected. Also the name of the LOVE file is still Mari0 + Portal too xP
Not that I'm trying to bug you... just hoping maybe it helps for you to know...

EDIT: It's LOVE 0.8.0 if anyone wanted to know
Alright now I feel like 'm needlessly nitpicking but just to make sure... I couldn't help but notice that ingame for 1.0 it says the mod version is 0.9.9 (the file is Mari0+Portal 1.0). Did I do something wrong, or...?


Return to “Modding”

Who is online

Users browsing this forum: CoolJulianXD, Technochips and 2 guests