Streaming game development: https://www.twitch.tv/stabyourself Image

All About Tilesets - Create Tiles In 10 Easy Steps!

Mapping related threads and questions go in here!
Superjustinbros
User avatar
Posts: 2101
Joined: 29 Mar 2012, 20:39
Reputation: 132
Contact:

Post » 23 Jun 2015, 20:13

You're required to use an image editor that has transparency, otherwise your tiles will have each and every single property applied at once, which is no good.

Salted_Candle
User avatar
Posts: 1
Joined: 05 Aug 2015, 08:35
Reputation: 0
Contact:

Post » 05 Aug 2015, 10:46

I seem to have some trouble with making a custom coin tile.

It shows it in the 'custom' part of the level editor, but when I put it down it shows it as a regular coin. It also shows its main color in the level editor map and it shows the custom tile itself when show on the title screen, but otherwise it doesn't show it. I put the right setting to make sure it is a 'coin tile' and its not possible to jump on it or anything its not supposed to be. Please help.

Technochips
User avatar
Posts: 700
Joined: 12 Mar 2015, 16:05
Reputation: 198
Contact:

Post » 05 Aug 2015, 13:23

You can make custom coins or ? blocks, but it's will replace the normal coin and the normal block, and you can't make multiple different coin.

ShadowLink1231
Posts: 4
Joined: 19 Aug 2016, 17:31
Reputation: 0

Post » 19 Aug 2016, 17:40

Alright, so I'm making tiles, making it so that they're collidable but not portalable, putting it in the template, blah blah blah, and when I put them into the game, doing exactly as this forum says, and placing them down, I test the level and Mario falls through the blocks. Here's the file. It's not complete, but it's what I have:Image Here's the dirt block that's working properly: Image, and here's one that's not working right; Image What am I doing wrong?

QwertymanO07
User avatar
Posts: 1314
Joined: 05 Oct 2012, 07:58
Reputation: 377
Contact:

Post » 19 Aug 2016, 18:03

When I downloaded the image, the background was white rather than transparent. If this is true of the file rather than just an error when you uploaded it, that's where your problem is.

ShadowLink1231
Posts: 4
Joined: 19 Aug 2016, 17:31
Reputation: 0

Post » 19 Aug 2016, 19:14

QwertymanO07 wrote:When I downloaded the image, the background was white rather than transparent. If this is true of the file rather than just an error when you uploaded it, that's where your problem is.


Okay, thanks, that helped.

ShadowLink1231
Posts: 4
Joined: 19 Aug 2016, 17:31
Reputation: 0

Post » 19 Aug 2016, 20:06

Hey, me again, sorry. I tried the transparency thing, and that worked, but only for one tile. As in one tile was the max I could input with it continuing to work. this is the one that worked: Image That one had collision detection. These ones, also in transparency work alone, but together in the green tileset (This one: Image) they do not work with collision detection. Can anyone help with this one?

QwertymanO07
User avatar
Posts: 1314
Joined: 05 Oct 2012, 07:58
Reputation: 377
Contact:

Post » 19 Aug 2016, 21:10

I managed to get it to work just fine after rotating the tile, even after inserting it into the green tileset and removing that tileset base's white background.

Image
(Also, you've been embedding images wrong. You have to copy the URL after right clicking it and selecting "View Image".)


Return to “Mapping”

Who is online

Users browsing this forum: No registered users and 5 guests

cron