StudioMDL Help

Feel free to showcase your own projects!
HAPPYFACES
Posts: 521
Joined: 02 Jun 2012, 03:40
Reputation: 25

Post » 27 Feb 2014, 01:19

Alright, so I need some god damn help.
My friend found a model that replaced the AK47 with a gold (for whatever reason) Assault Rifle from Halo/Halo 2 in Left 4 Dead 2. Unfortunately there were no reload animations.
So I say, alright, I'll take this and make some reload animations. Lucky me the developer of the reskin included the .smd files.
Yadda yadda, 3ds Max animating, crappily of course, done.
I go to compile the smd's into a set of source-readable files, the .qc looks good... And I get this from StudioCompiler:

WARNING: Event 0 (frame 79) out of range
in reload_layer
WARNING: Event 0 (frame 91) out of range in reload_layer
ERROR: Exiting
due to Errors
ERROR: Aborted Processing on 'v_models\v_rifle_ak47.mdl'

And I'm like... There is no frame 79 or 91. It's 78 frames total, AND whatever this "Event 0" is, nothing is out of range. There isn't some object twenty million units from the source as far as I know.

I've looked everywhere, the closest thread I could find was on gamebanana and there was no answer to the problem.
So, I ask of you, anyone who's done extensive modelling for the Source engine, do you have an answer to this dilemma?

Compiling was done; note to self, pay MORE attention to the values in the .qc file.

Now, I've compiled the model and L4D2 doesn't crash on startup, hooraaayyyy~!

However upon testing the rifle, on reload the model disappears and the view slowly turns to the left, then turns back to the right at the same speed, then the model magically reappears. Once again I'm trying to see what could cause this in the .qc file, but I'm not so sure that's what it is. Is it my .smd file doing a thing?

EDIT:
Thanks guys, you're all great help. Especially you, Camewel! God your avatar is beautiful, you sexy sonofabitch.

I've tried a lot of fixes for this, nothing seems to work... Probably because the fixes are for older versions of Source. Luckily I've somehow removed the slow turning problem, so it's "playable" but I dislike the fact all the work I've gone through for a custom reload animation can't be seen.

Return to “Game development”

Who is online

Users browsing this forum: No registered users and 1 guest

cron