Streaming game development: https://www.twitch.tv/stabyourself Image

Not Tetris 2 can't start - gameB.lua not found - Linux

Problems running games? Right in here.
TheLastProject
Posts: 2
Joined: 26 Jan 2013, 15:44

Post » 26 Jan 2013, 15:51

I'm having issues running Not Tetris 2 on my Gentoo system.
I've tried both love 0.8.0 and 0.7.2-r1 from the official repositories: http://gentoo-portage.com/games-engines/love, but both give the same error message:

Code: Select all

ruben@fox ~/Games/Stabyourself/Not Tetris 2 $ love Not\ Tetris\ 2.love
Warning, quality setting failed! (Result: buffers: 0, samples: 0)
Error: main.lua:3: module 'gameB.lua' not found:
   no file "gameB/lua.lua" in LOVE game directories.

   no extension "gameB.lua" in LOVE paths.

   no field package.preload['gameB.lua']
   no file './gameB/lua.lua'
   no file '/usr/local/share/lua/5.1/gameB/lua.lua'
   no file '/usr/local/share/lua/5.1/gameB/lua/init.lua'
   no file '/usr/local/lib/lua/5.1/gameB/lua.lua'
   no file '/usr/local/lib/lua/5.1/gameB/lua/init.lua'
   no file '/usr/share/lua/5.1/gameB/lua.lua'
   no file '/usr/share/lua/5.1/gameB/lua/init.lua'
   no file './gameB/lua.so'
   no file '/usr/local/lib/lua/5.1/gameB/lua.so'
   no file '/usr/lib/lua/5.1/gameB/lua.so'
   no file '/usr/local/lib/lua/5.1/loadall.so'
   no file './gameB.so'
   no file '/usr/local/lib/lua/5.1/gameB.so'
   no file '/usr/lib/lua/5.1/gameB.so'
   no file '/usr/local/lib/lua/5.1/loadall.so'
stack traceback:
   [C]: in function 'require'
   main.lua:3: in function 'load'
   [string "boot.lua"]:378: in function <[string "boot.lua"]:373>
   [C]: in function 'xpcall'


This only happens with Not Tetris 2. The other games I've tried (mari0, Order of Twilight, Ortho Robot, Trosh) work perfectly fine.

If any additional info is needed to help me, I'll be happy to give this.

Thank you for your time.

Automatik
User avatar
Posts: 1076
Joined: 20 Jul 2012, 17:54

Post » 26 Jan 2013, 15:59

Are you sure you have the same error message when using 0.7.2 ?
Because Not Tetris 2 only work with 0.7.2, and I don't think you can have this kind of crash with 0.7.2 (the "require("something.lua") don't work")

TheLastProject
Posts: 2
Joined: 26 Jan 2013, 15:44

Post » 26 Jan 2013, 18:04

Apparently, I had both version 0.8.0 and 0.7.2-r1 installed, and Gentoo decided to use 0.8.0. Until I figure out how to tell it which version to use, I have removed version 0.8.0.

Luckily, love outputs the version number if you run "love --version", which made me find out what was going wrong.

So well, thanks for making me check this. The issue really is solved by downgrading to 0.7.2-r1.

Long story short: I need help figuring out how to use this Operating System, not how to fix a bug with love.


Return to “Technical support”

Who is online

Users browsing this forum: State sponsored guitar solo and 0 guests