Now running on a new server. Stuff still needs to be straightened out. Please see the details here.
Known issues: MagicDNS down, mailing list down, email (including registration emails) down, forums still need work. Please report issues with anything else to saso@stabyourself.net.

My Mappack Vanished

Problems running games? Right in here.
User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 08 Jun 2012, 04:26

I had just finished lev.9 saved exited, and when I came back to it, the whole mappack was gone. It's folder is still there, but nothing inside. Luckily I still have the zip of the 1st 6 levels but the new 3 levels are gone. Any idea's what may have happened and if I might be able to get them back?

User avatar
Lawnboy
Posts: 836
Joined: 03 Feb 2012, 02:24

Post » 08 Jun 2012, 05:07

I know that they are gone, and you can't get them back.
Don't know what you did with saving, though.

User avatar
Sašo
Stabyourself.net
Posts: 1415
Joined: 06 Jan 2012, 12:07

Post » 08 Jun 2012, 11:08

OS, version, mappack, any errors when closing?

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 08 Jun 2012, 12:09

On win7, Mair0 1.6, Mappack: viewtopic.php?f=12&t=1881 , no errors. Forgot to say (very late trying to figure this out) I had just added a background pic to its folder then told the game custom background. I guess I didn't name it right because it didn't show. I thought I had unchecked custom just before closing (guess not). When I reopened the game the mappack was gone, just an empty folder.

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 10 Jun 2012, 01:31

Update on vanished mappack:
I managed to find out that it was some how deleted. I was able to recover it. I wasn't really able to make anything out of it. Here's a link to the recovered files to see any of you can make anything out it. http://www.mediafire.com/download.php?g4o9kcutqqlay4x

Maurice
Stabyourself.net
Posts: 2143
Joined: 01 Feb 2012, 20:19

Post » 10 Jun 2012, 13:23

The only case where the game would delete your mappack is if the folder has any of these names:
"dlc_a_portal_tribute", "dlc_acid_trip", "dlc_escape_the_lab", "dlc_scienceandstuff", "dlc_smb2J", "dlc_the_untitled_game"
Since that isn't the case here, the game did not delete your mappack.

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 11 Jun 2012, 12:23

Guess what, that's right it happened again. I was editing/creating (& nothing else) my new level 9 last night. I went to tweak it a hair just now and it was gone. Maybe the program got corrupt somehow and that's why this is happening? If some I'll just uninstall and reinstall to see if that will help.

Maurice
Stabyourself.net
Posts: 2143
Joined: 01 Feb 2012, 20:19

Post » 11 Jun 2012, 12:32

The game removes files in the following cases:
- On download error in the DLC get. This can only remove the files that are marked as DLC in our database though, and there currently isn't any DLC (the one that's in the game is "on-disc".)

- You reset your mappacks. This will only delete "smb" and "portal" mappacks.

- The case above where it deletes the following folders:
"dlc_a_portal_tribute", "dlc_acid_trip", "dlc_escape_the_lab", "dlc_scienceandstuff", "dlc_smb2J", "dlc_the_untitled_game"

Thus, it's impossible that it was the game that deleted your mappack.

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 11 Jun 2012, 13:39

Yea, I thought it might the pc it self, I was just really hopping it wasn't. I just don't know why or how it's doing it.

User avatar
Sašo
Stabyourself.net
Posts: 1415
Joined: 06 Jan 2012, 12:07

Post » 11 Jun 2012, 14:18

Löve has a history of being detected as a false positive. Depending on antivirus you're using, it could be preventing file writes and removing/quarantining changes it makes. It's one of the possibilities.

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 11 Jun 2012, 14:45

For antivirus, I'm using Bitdefender Antivirus Plus 2012. This is the 1st time i've had this problem.

User avatar
Sašo
Stabyourself.net
Posts: 1415
Joined: 06 Jan 2012, 12:07

Post » 11 Jun 2012, 15:25

Try disabling it when editing maps with Mari0. It's a long shot but it's slightly more likely than hard drive problems.

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 11 Jun 2012, 21:07

Alright, I turned off the antivirus and started making/editing my mappack again. I made level 7 (world 2-3) yet again, and after I saved my work leave it open as I go into it's folder. This is what I see:
Image
What's wrong with this pic?

User avatar
Sašo
Stabyourself.net
Posts: 1415
Joined: 06 Jan 2012, 12:07

Post » 11 Jun 2012, 22:53

Does saving as some other level work? As in, different number?

User avatar
Q Mark
Posts: 96
Joined: 12 Feb 2012, 05:10

Post » 11 Jun 2012, 23:38

If by that you mean recreate it elsewhere (ex. make 2-1_1 look just like 2-3) and save it, then no. In fact after I closed Mari0 completly, all the mappacks were gone, folders and all. I uninstalled & reinstalled Mari0, kept the antivirus turned off (just to be safe) and it seems to be working (for now).